No announcement yet.


  • Filter
  • Time
  • Show
Clear All
new posts

  • ACPI to MPS

    Hi, i changed my PC from APCI Multiprocessor to MPS Multiprocessor, to resolve IRQ sharing conflicts (loads of stuff on 16).

    All the drivers reinstalled OK and I have 2 lots of MPS Multiprocessor listed and no individual entries for CPU like before.

    When i run passmark, its clear its only using 1 core.

    Can i resolve this?



  • #2
    For people who don't know what skiv71 is referring to. He is talking about switching the hardware abstraction layer (HAL) in the Windows kernel. Microsoft provide several different versions of the Windows kernel to match different PC hardware. In general you would never want to manually change this as it is correctly set when Windows is installed. Selecting a wrong kernel will result in a dead machine.

    MPS = MultiProcessor Specification.
    ACPI = Advanced Configuration and Power Interface
    (Note that is is not APCI as in skiv71 post).

    But all this is probably irrelevant. The newer versions of PerformanceTest should detect all available cores and CPUs and use them. You can also force the issue from the PerformanceTest Edit / Preferences window.


    • #3
      yes thanks mr. passmark, i want the MPS HAL to alieviate IRQ sharing issues.

      I understand the CPU's arent shown in Device Manager because they are read as part of the ACPI scheme info.

      I opened CPUID and it definitely recognises both cores, as does task manager.

      I'm using the version of PM that fixed the core2duo cpu initiatilisation fault, is there another now?

      Do i understand that whilst ACPI natively supports CPU idle to reduce temps @ o/s level, the non ACPI (i.e. MPS) doesnt.

      Assuming this to be the case, i've enabled C1E and EIST in the bios.



      Oh, i just checked and i was using the latest version.

      Just looking in task manager and i'm reading funny CPU usage... Core 1 sits @ around 44% and Core 2 @ 0%. System idle says 99% though... i dont think thats right :-s

      Edit 2..

      When i run Perf Test, CPU usage goes to 100% on each graph, but the result is typical of a single core.

      I checked the prefs, and 2 processes are specified

      Last edited by skiv71; Sep-26-2006, 12:13 AM.