No announcement yet.

Unable to Edit TestCase with HTMLEditor

  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to Edit TestCase with HTMLEditor

    I want to update an existing TestCase with the integrated HTMLEditor. When I click on the [...] Button on the left side the editor opens normally, but I cannot make any changes in the text (The 'Insert', 'Format' and 'Table' MenuItems are disabled).
    I tried a few things and found out, that when I just hit the Enter key an error message appears which says:

    "Unable to open temporary html file at;
    Please check directory exists and you have write permission."

    We've tried on different systems with Vista and 7, but nomore permission on any system. It worked perfectly a few weeks ago and there were no software changes since then. Due to this I think it's caused by a Win Securtiy Update.

    I hope you can help me.
    Best Regards

  • #2
    Sounds a bit like this issue.

    What was the full path of the temp file?
    Do you have file create and write permission that location?


    • #3
      Thanks for your reply.

      I already had a look to this post. But that's a different problem, because i can modify the TestCases in the 'normal' edit window. I also can rename, delete and create TestCases and Projects.

      The full path shown in the message is user\app\local\temp\testlog\
      I have full access to this path. I tried to find this path in any .ini or registry key, but couldn't find it anywhere.



      • #4
        This path is retrieved from a Windows API call, and on windows 7 systems should be C:\Users\<current username>\AppData\Local\TestLog, so even if the expected location has been edited it should still be able to create the file (unless the new location does not have the correct permission set).

        Can you please check the current folder's (user\app\local\temp\testlog\) effective permissions, (Properties -> Security -> Advanced -> Effective Permissions) by clicking the select button and then entering the current user name. It may be that there is a deny permission being inherited that is preventing the file from being created / written (it can still show full control permissions available in the normal security settings properties despite the deny permission).

        It's unlikely a windows update would change this path but it is possible that an update to any security software you have installed may have as the location can be changed by editing the registry (the path should be stored at HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Explorer\User Shell Folders -> Local AppData). Do you have any security software installed that could be interfering with the file creation?


        • #5
          Hi Tim
          I checked the permissions and i have full access (adminstrators and system also).
          Then i checked the security software (we're running Symantec AntiVirus). First i saw that the last checked file shown in protocol was the missing tmpTestLogHtml.html (in path C:\Users\<current username>\AppData\Local\TestLog), which means that the file must have been there.
          Then i deactivated all security tools (even Windows Defender), but editing with HTMLEdit is still impossible.


          • #6


            The Problem got fixed with Build 1029.

            Thank You.