No announcement yet.

New install - WLAN card not showing

  • Filter
  • Time
  • Show
Clear All
new posts

  • New install - WLAN card not showing

    Running XP SP2 w/ Intel Pro/wireless 3945ABG card. Driver ver

    Works fine using Intel client, WZC, and a few other wireless clients tested on wireless networks. For some reason Wirelessmon is not seeing it. Running in eval mode. Any help appreciated.

    Below is the dubg log.

    0.000s - DEBUG: Starting...
    0.015s - DEBUG: WirelessMon V3.0 Build: 1002
    0.015s - Debug: OS 5.1.2600.2 (2.0)
    0.031s - DEBUG: New Instance of WLAN802_11 class initialized successfully
    0.031s - DEBUG: Service control manager opened
    0.047s - DEBUG: Network Driver Interface service opened
    0.047s - DEBUG: Network Driver Interface started
    0.062s - DEBUG: Network Card Service has been started successfully
    0.078s - DEBUG: WZCSVC Service has been requested to stop
    1.578s - DEBUG: WZCSVC Service stopped
    1.594s - DEBUG: InitDialog start
    1.609s - UpdateHexConst - numHexs: 0 - imgwidth: 0 - imgHeight: 0
    1.656s - Config Vals - Sample Time: 3000 - Delay time: 10
    1.687s - SummaryProc WM_INITDIALOG start
    1.687s - SummaryProc WM_INITDIALOG end
    1.906s - DEBUG: Tab Control has been created successfully
    1.922s - DEBUG PERF: Found perf functions in DLL
    1.937s - DEBUG: Graphic has been Initialized successfully
    1.953s - InitCounter start
    3.531s - DEBUG: All strings Intel[R] PRO_Wireless 3945ABG Network Connection - Packet Scheduler Miniport
    3.547s - DEBUG: Intel[R] PRO_Wireless 3945ABG Network Connection - Packet Scheduler Miniport
    3.578s - DEBUG: Broadcom NetXtreme 57xx Gigabit Controller - Packet Scheduler Miniport
    3.594s - DEBUG: MS TCP Loopback interface
    3.609s - InitCounter finish
    3.640s - DEBUG: SetWindowPos
    3.656s - WM_MOVE start
    3.672s - WM_MOVE end
    3.687s - WM_SIZE start
    3.719s - WM_SIZE end
    3.734s - DEBUG: ListView_GetColumn
    3.750s - DEBUG: ListView_SetColumn
    3.781s - DEBUG: loop ListView_SetColumn
    3.797s - DEBUG: InitDialog finish
    3.812s - DEBUG: check mini mode
    3.828s - DEBUG: get user details
    3.859s - DEBUG: e1
    11.828s - DEBUG: SetupStart start
    11.844s - DEBUG: WLAN802_11->InitInstance
    11.875s - DEBUG: WLAN802_11->EnumerateDevices
    11.890s - EnumerateDevices start
    11.906s - EnumerateDevices finish
    11.922s - DEBUG: begin to find wireless card by function
    11.937s - DEBUG: Selecting wireless card, opened device driver
    11.969s - WLAN802_11App::GetAssociatedAP start
    11.984s - WLAN802_11App::GetAssociatedAP end
    12.000s - DEBUG: Begin to find access point nearby
    12.015s - DEBUG: SetAccessPoint entry
    12.047s - DEBUG: Created time strings
    12.062s - WLAN802_11App::GetAssociatedAP start
    12.078s - WLAN802_11App::GetAssociatedAP end
    12.094s - Got item count 0
    12.109s - DEBUG: set LVI
    12.140s - DEBUG: Get AP list information
    12.156s - GetAPList: GetAPList entry
    12.172s - GetAPList: m_dwIOCTL_NDISUIO_SET_OID_VALUE failed - 1167
    12.203s - GetAPList: sent m_dwIOCTL_NDISUIO_SET_OID_VALUE
    12.219s - 1167 The device is not connected.
    12.234s - GetAPList: GetAPList exit
    12.265s - Locking mutex
    12.281s - Turn off list view updating
    12.297s - Finished MAC matching loop
    12.312s - DEBUG: sorting list
    12.328s - DEBUG: sorted
    12.359s - Released mutex
    12.375s - DEBUG: flag secure
    12.390s - DEBUG: flag secure done
    12.406s - DEBUG: status text set
    12.437s - DEBUG: SetAccessPoint exit
    12.453s - DEBUG: DSConfig read OK
    12.469s - DEBUG: SetWLIP start
    12.484s - DEBUG: pDeviceList null or pDeviceList[card_index].pDeviceName null
    12.515s - SetWLStat start
    12.531s - SetWLStat end
    12.547s - DEBUG: SetupStart end
    12.578s - DEBUG: enter message loop
    12.594s - UpdateThread start
    12.625s - WM_PAINT start
    12.640s - WM_PAINT end
    15.437s - WM_COMMAND start
    15.500s - WM_COMMAND start
    16.281s - WM_COMMAND start
    16.344s - WM_COMMAND start
    17.625s - UpdateThread sample start
    17.672s - TIMER start
    17.734s - DoUpdate
    17.781s - SetWLStat start
    17.797s - SetWLStat end
    17.828s - TimerRun start
    17.844s - DEBUG: SetAccessPoint entry
    17.859s - DEBUG: Created time strings
    17.875s - WLAN802_11App::GetAssociatedAP start
    17.890s - WLAN802_11App::GetAssociatedAP end
    17.922s - Got item count 0
    17.937s - DEBUG: set LVI
    17.953s - DEBUG: Get AP list information
    17.969s - GetAPList: GetAPList entry
    17.984s - GetAPList: m_dwIOCTL_NDISUIO_SET_OID_VALUE failed - 1167
    18.015s - GetAPList: sent m_dwIOCTL_NDISUIO_SET_OID_VALUE
    18.047s - 1167 The device is not connected.
    18.062s - GetAPList: GetAPList exit
    18.078s - Locking mutex
    18.094s - Turn off list view updating
    18.125s - Finished MAC matching loop
    18.140s - DEBUG: sorting list
    18.156s - DEBUG: sorted
    18.172s - Released mutex
    18.187s - DEBUG: flag secure
    18.219s - DEBUG: flag secure done
    18.234s - DEBUG: status text set
    18.250s - DEBUG: SetAccessPoint exit
    18.265s - TimerRun end
    18.297s - UpdateCounter start
    18.312s - UpdateCounter end
    18.328s - UpdateWLBasic start
    18.344s - WLAN802_11App::GetAssociatedAP start
    18.359s - WLAN802_11App::GetAssociatedAP end
    18.390s - UpdateWLBasic end
    18.406s - CounterRun start
    18.422s - CounterRun end
    18.453s - TIMER end
    18.469s - UpdateThread sample end
    19.719s - WM_MENUSELECT
    20.234s - WM_MENUSELECT
    20.297s - WM_MENUSELECT
    20.359s - WM_MENUSELECT
    20.406s - WM_MENUSELECT
    20.453s - WM_MENUSELECT
    20.531s - WM_MENUSELECT
    20.562s - UpdateThread sample start
    20.578s - TIMER start
    20.609s - DoUpdate
    20.625s - SetWLStat start
    20.640s - SetWLStat end
    20.656s - TimerRun start
    20.687s - DEBUG: SetAccessPoint entry
    20.703s - DEBUG: Created time strings
    20.719s - WLAN802_11App::GetAssociatedAP start
    20.734s - WLAN802_11App::GetAssociatedAP end
    20.750s - Got item count 0
    20.765s - DEBUG: set LVI
    20.797s - DEBUG: Get AP list information
    20.812s - GetAPList: GetAPList entry
    20.828s - GetAPList: m_dwIOCTL_NDISUIO_SET_OID_VALUE failed - 1167
    20.859s - GetAPList: sent m_dwIOCTL_NDISUIO_SET_OID_VALUE
    20.875s - 1167 The device is not connected.
    20.890s - GetAPList: GetAPList exit
    20.922s - Locking mutex
    20.937s - Turn off list view updating
    20.953s - Finished MAC matching loop
    20.969s - DEBUG: sorting list
    21.000s - DEBUG: sorted
    21.015s - Released mutex
    21.031s - DEBUG: flag secure
    21.047s - DEBUG: flag secure done
    21.078s - DEBUG: status text set
    21.094s - DEBUG: SetAccessPoint exit
    21.109s - TimerRun end
    21.125s - UpdateCounter start
    21.156s - UpdateCounter end
    21.172s - UpdateWLBasic start
    21.187s - WLAN802_11App::GetAssociatedAP start
    21.203s - WLAN802_11App::GetAssociatedAP end
    21.234s - UpdateWLBasic end
    21.250s - CounterRun start
    21.265s - CounterRun end
    21.281s - TIMER end
    21.312s - UpdateThread sample end
    21.328s - WM_MENUSELECT
    21.344s - WM_COMMAND start
    21.375s - WM_COMMAND start
    21.390s - WM_COMMAND start
    21.406s - WM_DESTROY start
    21.437s - Finalize start
    21.453s - Save columns
    21.469s - 72 - 21.484s - 90 - 21.515s - 54 - 21.531s - 72 - 21.547s - 72 - 21.562s - 72 - 21.578s - 72 - 21.609s - 72 - 21.625s - 72 - 21.640s - 72 - 21.656s - 72 - 21.687s - Save window pos
    21.703s - Save config
    22.328s - UpdateThread sample start
    22.390s - TIMER start
    22.437s - DoUpdate
    22.500s - UpdateThread finish
    22.640s - Thread finished
    22.687s - FreeLibrary
    22.703s - Cleanup name strings
    22.719s - Close wifi handles
    22.734s - Close Wlan handle
    22.765s - Close event handle
    22.781s - Free Library
    22.797s - Restore Services
    22.812s - Finalize end
    22.844s - WM_DESTROY end
    22.875s - ID_FILE_EXIT end
    22.890s - ~SIGNALLIST start
    22.906s - ~SIGNALLIST end

  • #2
    It looks like the list of network cards isn't being returned by the NDIS driver correctly.

    Is the card currently connected to an access point when you are running WirelessMon, does it affect the start-up if you connect/disconnect first?


    • #3
      Originally posted by TimR View Post
      It looks like the list of network cards isn't being returned by the NDIS driver correctly.

      Is the card currently connected to an access point when you are running WirelessMon, does it affect the start-up if you connect/disconnect first?
      When I first installed it, I was using wired. I then tried making a wireless connection and still no list. I then removed wirelessmon, rebooted and connected to a wireless network reinstalled wirelessmon and still nothing.


      • #4

        The wireless client I was using was Cisco Secure Services Client. I tried disabling the service to try and use the windows client and no luck. In Cisco SSC though, with the service running I went under the Settings menu and unchecked Enable Client. This then allowed the windows client to work. Not sure why disabling the service didn't do the same.

        Anyway, so I tired wirelessmon and my card was there and it started working.

        The downside was that since it kills the WZC service, I lost my wireless connection. Is that the way it is suppose to work?

        What is the Cisco SSC controlling that breaks it?


        • #5
          WirelessMon can't access the network card while the Windows Zero Config is running as it can't gain control of the network card (only one program can be controlling the network card at a time), the same reason applies when third party/manufacturer software is running. They can't share access between the various programs.