Announcement

Collapse
No announcement yet.

Memtest86 does not go beyond "getting memory controller details"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Memtest86 does not go beyond "getting memory controller details"

    Since a couple of days I have kernel panics with a brand new iMac 2020 (64 GB RAM) running macOS Big Sur. To rule out if the RAM is defective, I wanted to run Memtest86 from the USB stick. Unfortunately, the boot process does not go beyond "getting memory controller details". The process gets stuck. Is there something I can do?

    Thanx,
    Gerson Nerger (CFG27

  • #2
    Sounds similar to this issue, which we had thought was a one off issue.

    Can you post the debug log from MemTest86
    https://www.memtest86.com/tech_debug-logs.html

    Comment


    • #3
      Sure ...

      Gerson Nerger (CFG27 MemTest86.log

      Comment


      • #4
        Can you open 'blacklist.cfg' with a text editor under EFI/BOOT/ of the USB flash drive and replace the text content of that file with the content in this post:
        https://forums.passmark.com/memtest8...9159#post49159

        Comment


        • #5
          I too am having this exact same problem on my new 2020 iMac 10-core i9 w/128GB RAM. Except here is my situation: My 2-month old iMac came with macOS Catalina. Memtest86 worked perfectly to diagnose two of the four sticks of RAM (purchased from OWC).

          While the two faulty sticks of RAM were being exchanged, I ran my iMac with 72GB of RAM using the existing 2x32GB OWC RAM, and the original 8GB of Apple RAM that came with my system when purchased. Memtest86 worked perfectly in this configuration.

          It was during this time I upgraded my new iMac to BigSur.

          The remaining two sticks of RAM arrived. I installed them to bring my system back up to 128GB.

          When I run Memtest86, the screen freezes at the exact same location "getting memory controller details".

          Memtest will halt at this point now regardless of how much RAM is in my machine, even with only the original 8GB of RAM.

          The only difference between before and now, is that I upgraded to BigSur. Nothing more.

          Is it possible upgrading my iMac to BigSur somehow prevents Memtest from working? Any ideas would be greatly appreciated.

          Comment


          • #6
            According to the internet, they updated the BIOS firmware during the BigSur update, and inserted a few new bugs. Seems they also broke Bootcamp Win10 booting when using a eGPU and bricking some other Mac models. So looks like they also broke MemTest86.

            Can you try the blacklist change above. If that doesn't fix it can you post the MemTest86 log file.

            Comment

            Working...
            X