No announcement yet.

Asus p8h61-m lx3 rev 1.0 all uefi MT hangs in menu

  • Filter
  • Time
  • Show
Clear All
new posts

  • Asus p8h61-m lx3 rev 1.0 all uefi MT hangs in menu

    Here is some logs and photos.
    Got bunch of old mbs to test and there is problem - UEFI MT hangs after loading part of main menu.
    Tryed 10.4 and 9.4. Both hangs. Old 4.3.7 run fine, no errors.
    Tryed on different sets of hardware "low-end" p8h61-m + pentium G840 + 2x4gb-1333 different modules and "high-end" p8h61-m + core i5-3570 + 2x4gb-1600 same modules
    Photos and 9.4 log from pentium set, two 10.4 logs from core i5 set.

    But there is some magic - if option SKIPSPLASH=1 is disabled UEFI MT loads and run tests, but with only one core enabled.
    After test is stopped MT, all graphics and resuls are shown, hang on returning to main menu.
    I thought it may be some video glitch, even tryed different monitor - samsung n720 (square 1280*1024) - no effect.​
    Attached Files

  • #2
    Photos of running 4.3.7 and 10.4 with one core.
    Attached Files


    • #3
      Very likely the problems are UEFI bugs.
      The initial versions of UEFI Bios from 10+ years ago were all pretty buggy.

      I assume there is no newer BIOS available for these boards?

      The log showed a lockup at a strange location however.
      2023-05-26 14:02:41 - Warning - no mouse detected

      Was there a mouse connected? (note that a mouse should not really be required, but wondering if connecting a mouse might fix this particular lockup).

      On the other hand the problems with UEFI and Multi-threading are well know.


      • #4
        Hard to believe, but connecting mouse solved issue!
        MT now can load and exit without hanging. Strange magic. Usually i do not use mouse when testing memory at all.
        But tests run only with one core. Trying to change this setting in menu brings message "CPUSEL cannot be set to multi-CPU mode due to UEFI firmware limitations".
        Recently tested bunch of Asus h61m-k + i5-3570 + 2*4gb - worked without issues. There was firmware 0801 2014-07-21, here is 0601 2014-03-27 - all versions last and latest.
        And tons of "WaitForEvent returned error: Invalid Parameter" in log.
        Attached Files


        • #5
          but connecting mouse solved issue!
          Shouldn't have. As no mouse is required.
          Likely another bug in this old UEFI BIOS.