No announcement yet.

Question about update FW.25 for USB loopback 3.0

  • Filter
  • Time
  • Show
Clear All
new posts

  • Question about update FW.25 for USB loopback 3.0

    Hi all,

    I have some USB loopback 3.0 FW 1.4 & FW 1.7 and want to update to FW 2.5. I already downloaded software from passmark website as below link

    After unzip the file, I run the file .exe and plug in the USB loopback 3.0 then press "Program" button. But the error message shows up as below

    Click image for larger version

Name:	IMG_6735.jpg
Views:	161
Size:	100.5 KB
ID:	49994
    I tried to click "Yes" for one USB loopback and click "No" for the other USB loopback. Then both USB loopback seems dead. No LED on after that.
    Can someone help to fix this issue? Thank you

  • #2
    At the risk of asking the obvious question (the same question as the one in the window).
    What hardware revision are you running?


    • #3
      If you had FW1.4 & 1.7 on your plugs, then most likely plugs are revision 1 and you should have clicked Yes.
      Did the updater tool show any error during the firmware update?
      Does Windows OS recognize the plug when it is inserted into the machine (Either in Windows Device Manager or USB connection chime when you insert/remove the device)? If it does, possibly the update process was interrupted, so you just need to run the FWUpdater again to load the firmware. The updater tool can be downloaded from here,


      • #4
        Thank you all. Finally, I can do it