No announcement yet.

Very low floating point math score.

  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    So maybe a device driver problem, or some 3rd party piece of software messing things up.


    • #17
      Cross reference to another post that appears to have a similar issue, but with the i7-7700 CPU.

      So as a summary, this seemed to help:
      - Turning on Intel Speed step in BIOS
      - Uninstalling Gigabyte bloatware (e.g EasyTuningService)
      - Full reinstall of Windows if above don't work.

      It still doesn't fully get to the bottom of the problem, but at least there are some things to try.

      Update: It was also determined that Dual Intelligent Processors 5 software (under ASUS AI suite) causes a problem for AMD ThreadRipper CPUs.


      • #18
        Was this problem solved ?


        • #19
          In my case yes. New win install, everything works as it should. Still trying to figure what was the problem in the first place. I've access to the troubled 8.1 installation, So I've just been fooling around trying to find the cause. Went through the 7700 thread looking for examples, and I can't find anything.

          MB is Asrock, and in the 8.1 installation is had some asrock autotuning thing installed. Uninstalled the thing, Speed step was on, also tried with it off, In both cases I'm still getting low Floating Point Math. It came at 2580 in the last test, it's going up/down by some 50 points. The other win installation is at 9000 (+-100). I'm thinking there's also an option that it's got something to do with some autotuning residue from the old MB/CPU combo that's still embedded in the system. But again not certain. It's curious that in 7700 case user also had similar increase when he fixed it. Roughly 3x.
          Last edited by dododa; May-04-2017, 11:30 PM.


          • #20
            hi, ive recently purchased fatality mobo with ryzen cpu...
            first few days was everything okay....but one day my pc got sluggish....playing youtube producing sound stutterin...fps drops in games...etc
            syntetic benchmarks were lookin all fine...except pass mark cpu floating point test...that one got crappy low...from 11.5k point (when it was new) to ~4.5k
            after a bit googlin i found nothing ive tryied reinstall success..
            then i reseted CMOS and everything got back to normal...
            so i did change bios settings one by one until ive got to ACPI HPET table...
            amd kinda says:
            Make sure the system has Windows High Precision Event Timer (HPET) disabled. HPET increases the polling resolution of the systemís timer for certain performance monitoring utilities and the increased poll rate can compromise everyday application performance. HPET can often be disabled directly in the BIOS.
            but in my case disabled HPET hurts my PC..
            so im wondering...amd failxD


            • #21
              AMD is giving out conflicting information. They are saying HPET should be off for performance reasons, but they are also saying it should be on when using the AMD Ryzen Master application which is used for overclocking to increase the performance. Which of course makes no sense.

              The way of measuring time on a PC has changed over the years. From oldest to newest the various hardware is,
              RTC, Real Time Clock
              PIT, Programmable Interval Time
              PMT, Power Management Timer
              HPET, High Precision Event Timer
              TSC, Time Stamp Counter

              You can tell the frequency of the clock (and this which one is in use) by using the Windows QueryPerformanceFrequency() call,

              Anyway all new systems should be using the TSC. So even if the HPET is enabled in BIOS, it shouldn't be used. So from that point of view it makes sense to turn it off.
              BUT the instructions from AMD for using the AMD Ryzen Master application tell you to turn it on in BIOS, then reconfigure Windows to use it. Why I don't know as this make little sense.

              Here is what I suspect is happening. When you overclock Ryzen inside of the O/S then the TSC clock also get effected (sounds like a bug in the CPU to me, but anyway). Meaning the clock is no longer accurate and benchmark frame rates won't be accurate either. So to avoid this problem AMD suggests you force the use of HPET when overclocking inside of the O/S. The HPET timer remains accurate regardless of CPU clock speeds. This isn't a problem I suspect if you overclock from BIOS.

              An inaccurate clock might also cause the video stuttering you saw.

              So by forcing HPET to be on you get an accurate clock back, but there is extra interrupt processing overhead required when you are using HPET.
              But if you aren't overclocking then you can leave HPET off I would think.


              • #22
                well the thing is that i didnt overclock it, cpu jumps up on its own to 4.1ghz, tho i did try ryzen masteronce , but since it was messing up with vddr voltages a bit than it got deleted


                • #23
                  tho i did try ryzen masteronce
                  One of the suggested changes when using the Ryzen Master application was to permanently change the clock source in Windows to be HPET. So even if you uninstall Ryzen Master, then it won't effect the clock source. I don't know if you did this or not.