Announcement

Collapse
No announcement yet.

Low 2D Performance scores

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Low 2D Performance scores

    I recently did a clean install of windows 10 1809. I installed all the drivers for it. I ran performance test 2D and got a very impressive score of 888. I have an NVidia Quadro M4000 with 417.19 driver. Then I installed all the windows Updates and to my amazement the best score I could only achieve was 680 with windows set at performance mode. Obviously, one of these updates have destroyed my 2D performance. If effects the 3D score too, but not as much. My complete test score was 6500 for the computer before these updates. Afterwards, the best I could achieve was 5700... using the very same settings. Any suggestions anyone on how to fix this extreme loss of performance and which updates it might of been? My 1809 ISO install file is the latest version given by Microsoft... so there wasn’t that many updates. I’d hate to start uninstalling windows updates and not fixing the loss of computer speed.

  • #2
    Could be lots of reasons.

    nVidia (once again) releasing drivers with bugs like this one,
    https://www.tomshardware.com/news/nv...ues,39195.html

    Patches to the O/S and CPU microcode to fix the Spectre class of security issues
    https://en.wikipedia.org/wiki/Spectr...vulnerability)

    The introduction of more and more "fluid" design elements into the Windows user interface
    https://www.techrepublic.com/article...fluent-design/

    Or it could have been some other change you made. e.g. different DPI settings, different monitor resolution, different environment (e.g. temperature).

    Comment


    • #3
      I definitely know it was one of Microsoft”s recent updates. Not sure which one precisely. Microsoft recently released an updated .ISO of 1809 March 2019 release... this version was very fast. I achieved 2D performance of 888. Everything being the same other than recent updates, the 2D speed dropped over 200 points. The drop was mostly with the advanced vectors and windows interface tests. For example, before the updates... both of these scores were around 120. Afterwards, around 62. I know Microsoft does release defective patches. Uninstalling these updates don’t help. Whatever changes these patches made, uninstalling them doesn’t repair the performance loss. Only a clean reinstall will work.

      Comment


      • #4
        advanced vectors and windows interface tests
        Both these tests make a lot of API calls. And this is what is impacted most by the Spectre patches.

        We had another customer report the following to us (we haven't verified it however).

        If you get the inspectre tool from Gibson Research it can report on what Spectre & Metldown patches have been applied and disable them. This will then restore the lost performance (but also reopen the security vulnerability). In our opinion, the security issues aren't critical for a home user (one user on a single machine). They are more critical in a server environment with multiple users however. So try disabling them and see if it restores the lost performance.

        Gibson Research has been around for a long time now and is well respected, so the tool should be safe to use.



        Comment


        • #5
          Click image for larger version

Name:	2E6C4977-34C0-42F5-B860-747D78F9F7D8.png
Views:	6172
Size:	49.0 KB
ID:	44535 Thank you for your advice. It is the spectre and meltdown patch. I downloaded the inspecter tool and disabled the Spectre and Meltdown patches. I ran my Passmark test again... I was impressed on how much faster my computer ran. As you can see... much better results thank you again!!!
          ​ ​​​​​

          Comment


          • #6
            both of these scores were around 120. Afterwards, around 62
            Microsoft (in a general sense) know there is a problem. See,
            https://www.microsoft.com/security/b...ndows-systems/
            But they use the description, "some benchmarks show more significant slowdowns". Kind of scary that 'significant' in this case means half the speed is lost.

            Great to hear it is fixed in any case.

            Comment


            • #7
              Just a comment in case anyone else passes by.......

              Had the same problem. AND just after a clean install of 2020 Windows10. The 'clean install' is the clue.
              Download THE OLD 2010 DX9 (2D) drivers from https://www.microsoft.com/en-gb/down...s.aspx?id=8109 and all will be well!

              Regards,

              Comment


              • #8
                Originally posted by ColinB View Post
                Just a comment in case anyone else passes by.......

                Had the same problem. AND just after a clean install of 2020 Windows10. The 'clean install' is the clue.
                Download THE OLD 2010 DX9 (2D) drivers from https://www.microsoft.com/en-gb/down...s.aspx?id=8109 and all will be well!

                Regards,
                how exactly do i install the older version? i downloaded the file u linked but there is no obvious way for me to install the older version as u stated. if its ok with u would u mind lettting me know in detail how to do so. thank you Click image for larger version

Name:	Untitled.png
Views:	1391
Size:	144.7 KB
ID:	49166Click image for larger version

Name:	pic 2.png
Views:	1393
Size:	75.7 KB
ID:	49167

                Comment


                • #9
                  ? the file directx_Jun2010_redist.exe link above is to a self extracting zip file. Once extracted to the directory of your choice you just run the DXSETUP.exe. Not sure what you have there. I would guess you would run the infinst.exe. The one you have is just another type of installer. If it does not work download from the above link and try again.
                  Main Box*i7 4790K*Z97 Extreme 6*2x8 gigs Crucial BS DDR3-1600*GTX 1070Ti*Samsung 860 EVO 500 gig*Samsung 860 EVO 1TB*Samsung 860 EVO 2TB*ASUS DRW-24B3LT*LG HL-DT-ST BD-RE*Corsair AX750 PSU*Fractal Design Define R4 case*Windows 10 Pro 64

                  Comment


                  • #10
                    I have the following conundrum for you.
                    Overclock cpu -> high score
                    Overclock ram -> low score 2d high score RAM
                    No overclock -> low score

                    I will continue to experiment. Something smells fishy with this 2d score

                    Comment


                    • #11
                      Low 2D Passmark, specifically PDF rendering, I have solved by deleting the TestPDF.pdf file in the Passmark directory and replacing it with a similar sized PDF file with similar content and renaming the new file as TestPDF.pdf. Whereas my previous PDF rendering score was 3, it's now 44, within expectations. Accordingly total 2D benchmark went from ~240 to ~480, also within expectations.
                      Apparently the original TestPDF.pdf file had become corrupted, as previous benchmarks had been normal. I had tried many of the solutions suggested here to no avail.
                      Processor: AMD FX 8320e, video card: XFX Ghost 2GB DDR5.

                      Comment


                      • #12
                        RobertB,
                        Don't do this. You are just hiding the problem not fixing it.
                        It isn't an apples to apples comparison and results can't be compared if you replace the PDF file with another one that (very likely) is easier to render with less graphics, etc..

                        If the TestPDF.pdf file was really corrupt (which we doubt) you can re-install PerformanceTest to get a clean copy. You can also view the file with Acrobat or any PDF viewer to look for corruption.

                        Much more likely it is a device driver / hardware issue.

                        Comment


                        • #13
                          David:
                          Thanks for your suggestions.
                          I have installed Performance 10 several times now, both 1010, and now 1011, all with the same result. I just reinstalled 1011 for the second time after reading your post.
                          The PM pdf test file was and is viewable and scrollable all the way through using Acrobat, both Acrobat XI and the newest version (2021xxx), so seems not to be visibly corrupt. What happens when PM 1010, and now 1011 execute the 2D PDF rendering benchmark is that the first image is presented, pause, then some text, then the final image, all in about 4 seconds. The benchmark result is either 3, or 4.
                          For some reason the TestPDF.pdf file is not liked, by my machine anyway! I have had no issues with any other PDF file, graphics file, or any file, or program. My drivers are the most recent from AMD for my video card, and Windows updates are current. I have no 'glitches' or errant behaviour of any kind, other than this one benchmark.
                          Anyway, the substitute file I chose to use was about 20 MB, a technical paper and had much text, many photos and maps, tables, etc, of similar content and complexity to the TestPDF in Passmark 10. All the other tests have yielded results within expectations; only the PDF rendering benchmark fails.
                          I'll continue to explore this; swapping out a video card, etc.


                          Comment


                          • #14
                            The final result of swapping several Radeon video cards and running PM 10 on two Windows 10 machines (one pre-latest update, one Windows post-recent update, then both post-recent update) and both with pre-AMD and post-AMD recent driver update is that for some reason the XFX Core HD 7870 2GB Ghost does not like the TestPDF.pdf file. Other cards (HD 7730 and HD 7770) work fine with the standard PM 10 TestPDF file, and a renamed Test file of similar size and complexity works OK with the 7870. After doing quite a bit of research from many sources couldn't find anything that I hadn't tried.
                            Pretty strange, but that's the way it is sometimes in computerland. I'll just leave it as a Mystery.

                            Comment


                            • #15
                              Thanks for running those tests. That XFX Core HD 7870 card is pretty old now. Pre Win10 and pre DirectX12. So drivers probably never got tested with some of the newer DirectX stuff (DirectWrite, Direct2D). So I would be inclined to think it is a driver issue. But it doesn't explain why the equally old HD 7770 works OK. So yes a mystery.

                              Comment

                              Working...
                              X