No announcement yet.

List of Motherboards with issues when running MemTest86 in multi-CPU selection modes

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hello

    This is my configuration that I use for the memtest through the network, only in the Asus Prime Z490-P model it does not start, the screen remains frozen with the message "Testing multiprocessor support", someone could help me with the configuration blacklist.txt mt86.txt


    • Ivan,

      Can you post the debug log. The log contains the exact text name for the motherboard that we can use to match against. Can you also check you are running the latest BIOS. If you are running the latest BIOS, then we can report the problem to ASUS.


      • Hey y'all, first post.

        I want to add some results concerning various ASUS Sandy/Ivy Bridge-E / -EP boards.

        Board P9X79 WS
        BIOS 4901
        CPU i7-3820 @3.60GHz; Xeon E5-2690v2 @ 3.00GHz
        Board P9X79-E WS
        BIOS 1704
        CPU i7-4960 @3.60GHz; Xeon E5-1680v2 @3.00GHz
        Board Z9PE-D8 WS
        BIOS 5802
        CPU Xeon E5-2690v2 @3.00GHz (single- and dual-socket configurations)


        Problem: complete system hang/freeze while running test#12, on all boards, in both single- and dual-socket cpu configs, as well as single-, dual- and quad-channel memory configs.

        Final Fix/Workaround: Adding entries for all boards to the file blacklist.cfg.

        Blacklist Entry: "P9X79 WS",ALL,EXACT,TEST12_SINGLECPU (Similar Entries for all 3 boards).

        Memtest version used: V8.4 Pro Build: 1001 (using V9.4 now, did not evaluate if the error still occurs)


        After I had begun to use MemTest Pro (after some time using MemTest Free), the system(s) ran into a complete freeze during the first run of test #12.
        I was testing various RegECC DIMMS on the dual-Xeon board (Z9PE-D8 WS), so I was suspecting one or more defective DIMMS.

        But the situation could be reproduced using the other X79 boards I had in stock:
        • with the P9X79 WS, the freeze occured while using the i7-3820 as well as one E5-2690v2 and 1 to 4 pcs. Kingston KHX1600C9D3/4G (PC3-12800; DDR1600; CL9) DIMMs.
        • with the P9X79-E WS, the freeze occured while running the test suite using the i7-4960 and 4pcs. Kingston KHX1866C11D3/8G (PC3-14900; DDR1866; CL11) DIMMs.
        • Configurations used with the Z9PE-D8 WS: single- and dual-socket setup, up to 4 pcs. of Samsung M386B4G70DM0-CMA3 as well as up to 4 pcs. of Samsung M386B4G70DM0-CMA4 (PC3-14900; DDR1866; CL13) RDIMMs.

        After spending some time reading here in the forum and the FAQs, I suspected some sort of compatibility issue regarding the chipsets (as X79 and C602 are of one family) AND Asus as manufacturer, with memtest running in MP mode, resulting in the hang/freeze.
        Since the freeze occured in the same way, while using different CPU configs and DIMM types, AND since there are blacklist entries for the succeeding models like Z10PE-D8 WS, my conclusion was that it had to be either chipset and/or manufacturer related.

        Then I tried out test runs using options: round robin, sequential.
        Round robin did work in some way, but produced some strange looking and not before seen entries to the memtest86.log file.
        Sequential caused early hangs/crashes in during test 2.
        I did not want to dispense of running the test suite in MP mode entirely, so I tried out the possibility to add the board's descriptions to the blacklist.cfg file, setting the options: ALL,EXACT,TEST12_SINGLECPU.

        This fixed the issue and the test suites did run and complete all four runs.

        Just for curiosity's sake, and to check if the freezes were not caused by some general config error of mine, I later ran the complete suite on an AsRock EP2C621D12 WS board with two Xeon platinum 8124M CPUs and 4 pcs. Kingston KSM 32RD8/16HDR; 16GB PC4-3200 CL22 RDIMMs (Dual-socked, dual-channel mode) with the stock blacklist file.
        As I expected, the test suites comleted all 4 runs wihout any hassle.


        • Hello all

          I have a motherboard "PRIME-Z490-P when boot to PXE in the process of "testing multiprocessor support" is freezes and don't start the test, I using the mestest site 8.6, anotherds motherboard run good this is the only version that not work

          this is the information complete of the motherboard
          PRIME Z490-P
          Bios Version 1621
          Intel core i7 10700
          Speed 299Mhz



          • You can try to edit the 'blacklist.cfg' file and add your motherboard there and disable multiprocessor support, e.g.


            • Another SuperMicro board not supported:

              3.3 (latest)
              2x e5-2650v2
              System reboots on "Testing Multiprocessor support"

              Everything works fine if I blacklist it with:



              • We'll add it t the list of buggy motherboards.


                • Something weird happening, blacklist.cfg after a fresh download/dd is being recognized as a binary file? Should this not be plaintext? My config above is getting wiped after a successful boot?


                  • blacklist.cfg after a fresh download/dd is being recognized as a binary file?
                    By what?
                    It is a text file (but maybe UTF-8 / UTF-16, I would need to check).


                    • Originally posted by David (PassMark) View Post

                      By what?
                      It is a text file (but maybe UTF-8 / UTF-16, I would need to check).
                      Opening in vim it looks like a ton of weird encoding/line endings. Opening in VSCode it thinks its a binary file, which I'm guessing just means it can't figure out what it is suppose to be.

                      I edited my config line to the end of the file and it seems to be withstanding reboots now. Not sure what was going on.


                      • Maybe your USB flash drive is failing?


                          • Motherboard model number : X9DRT
                          • BIOS version: 03.54
                          • CPU: E5-2620
                          When trying to run memtest. It hang after 2 sec.
                          See attachment
                          Attached Files


                          • ikus060,

                            I think you are confused. You are using Memtest86+ (with a plus) and that isn't' our software. You need to contact the developer, Sam Demeulemeester, for support with that software.


                            • Reporting issue with Gigabyte TRX40 Aorus Master rev 1.1 with FD bios using Threadripper 3990X.

                              Stuck on testing multiprocessor support. Memtest86 v10

                              Using memtest86 v8.3: able to complete testing with single core mode. Multicore mode would freeze within 2 min.

                              How is this still an issue with new motherboards like this so many years on. Is it expected that the motherboard manufacturers will fix this if they know about it?


                              • Ah, I thought I was alone!

                                Asus Zenith II Extreme Alpha, with BIOS 1603.
                                Amd Threadripper 3990X.

                                Memtest86 v10.0, locks up under multi.

                                I'll post the log after MS's memory scan runs its course. Finally got the thing to run.