Announcement

Collapse
No announcement yet.

ryzen 9 5900x low scores, good temps and freqs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    So I did a search on "ASUS" on C:\ having uninstalled every single ASUS installation, and I deleted all the file folders left behind (why didn't it delete those?!). I still had hundreds of results and the ASUS services were still listed in Services, although of course they were not started. I just thought how ridiculous it was that it hangs around like a virus, so I did a Windows 'refresh' reset. The first thing I did upon getting into Windows was downloading PT 10.

    I'm pleased to report my scores are back exactly where they should be. Phew Floating point math is up 6600, and single core performance up 450. Now my floating point math in particular is one of the highest scores on the chart.

    I still think it would be good to hear what ASUS have to say about this. I disabled 'Install Armoury Crate' in the BIOS before my Windows refresh and that led to absolutely no trace of any ASUS software upon starting Windows.

    Do you think it's safe to install the AMD Chipset Drivers? I have avoided Gigabyte's XTREME Gaming Engine for GPU overclocking as I think I read this could cause issues, and instead I'm using NVIDIA Inspector (an open source program with absolutely zero bloat!). My CPU test scores remain good.

    Click image for larger version  Name:	Capture2.JPG Views:	0 Size:	53.7 KB ID:	50098​​
    Attached Files
    Last edited by ElectrodeX; 02-20-2021, 03:48 PM.

    Comment


    • #17
      Comparison of floating point math with ASUS software installed (image 1), and not. Interestingly there is a different shape to the curve as the different threads load up. Maybe this means something.

      Click image for larger version

Name:	Floating point math.JPG
Views:	732
Size:	34.8 KB
ID:	50101

      Click image for larger version

Name:	Floating point math 2.JPG
Views:	738
Size:	34.0 KB
ID:	50102

      Comment


      • #18
        ASUS replied that they are looking into it. If we hear anything I'll let you know.

        Comment


        • #19
          ASUS claim they are not able to reproduce the issue as would like like to know the motherboard model and BIOS version(s) you are using.

          Comment


          • #20
            The motherboard is the ROG Strix X570-I Gaming

            BIOS is version 3406, but I had the same issue on 3001.

            Comment


            • #21
              Another question from ASUS. Where did you get the AI Suite 3 software from. (CD in the motherboard box, ASUS web site, somewhere else?)
              It is a bit of a strange question, as the version number should identify the install package well enough. Unless they thought that some packages are corrupt, infected, or their version control is poor.

              Comment


              • #22
                That is a bit of a strange question.

                In the ASUS Armoury Crate software, it was listed as one of the downloads under 'utilities' and so it downloaded and installed it via the ASUS platform itself.

                Comment


                • #23
                  I want to report that I had the same issue and was able to resolve it!

                  I did two things:
                  1) [This is probably not necessary] I followed the instructions at the bottom here. Specifically, I ran this command: "bcdedit /deletevalue useplatformclock". This helped with the floating point benchmark, but not so much with the single CPU benchmark.
                  2) [This step is probably sufficient] As discussed in this thread, I did a "Windows 10 in-place upgrade".

                  My scores, which used to be high: https://www.passmark.com/baselines/V...d=137016602631
                  Went to fairly low values after install AI Suite 3: https://www.passmark.com/baselines/V...d=137640555928
                  After doing the above two steps, my scores are actually now higher than the first baseline, which is expected since I upgraded RAM. Unfortunately, I cannot resubmit the baseline now that the issue is resolved.

                  What more: the in-place upgrade kept all my applications. I'm still testing things, but as far as I can tell it didn't break any of the application installs.

                  Comment


                  • #24
                    UPDATE 1/March/2021:
                    We have been in discussion with ASUS about the issue.

                    After testing they confirmed a bug in their AI Suite 3 software related to the HPET (High Precision Event Timer) clock.
                    They are saying it will be fixed in a "future" release, but at the moment they can't tell us when this will happen or the version number of the new release. They also didn't describe the exact nature of the problem. Not sure why all these big companies need to be so secretive, sigh.

                    This HPET issue has been a very long running issue for Ryzen CPUs. Here is a copy of what I wrote 4 years ago below.
                    If you do a Google search there are 100s of pages discussing this HPET issue.

                    AMD is giving out conflicting information. They are saying HPET should be off for performance reasons, but they are also saying it should be on when using the AMD Ryzen Master application which is used for overclocking to increase the performance. Which of course makes no sense.

                    The way of measuring time on a PC has changed over the years. From oldest to newest the various hardware is,
                    RTC, Real Time Clock
                    PIT, Programmable Interval Time
                    PMT, Power Management Timer
                    HPET, High Precision Event Timer
                    TSC, Time Stamp Counter [and there are two versions of this, Invariant TSC, (ITSC), and original flavour TSC]

                    You can tell the frequency of the clock (and this which one is in use) by using the Windows QueryPerformanceFrequency() call,

                    Anyway all new systems should be using the TSC. So even if the HPET is enabled in BIOS, it shouldn't be used. So from that point of view it makes sense to turn it off.
                    BUT the instructions from AMD for using the AMD Ryzen Master application tell you to turn it on in BIOS, then reconfigure Windows to use it. Why I don't know, as this make little sense.

                    Here is what I suspect is happening. When you overclock Ryzen inside of the O/S then the TSC clock also get effected (sounds like a bug in the CPU to me, but anyway). Meaning the clock is no longer accurate and benchmark frame rates won't be accurate either. So to avoid this problem AMD suggests you force the use of HPET when overclocking inside of the O/S. The HPET timer remains accurate regardless of CPU clock speeds. This isn't a problem I suspect if you overclock from BIOS.

                    An inaccurate clock might also cause the video stuttering you saw.

                    So by forcing HPET to be on you get an accurate clock back, but there is extra interrupt processing overhead required when you are using HPET.
                    But if you aren't overclocking then you can leave HPET off I would think.

                    It is a complex mess of inaccurate & partial information. So maybe AI Suite 3 was forcing HPET to be turned on and even if you uninstall it, HPET remains turned on.

                    Comment


                    • #25
                      Interesting stuff. I did come across HPET in some forum threads before I did my reinstall but had no idea how to change it because I didn't have a BIOS setting for it.

                      At least now we know for sure what it is and how to avoid it and fix it if necessary (reinstall Windows).

                      I'm glad ASUS have admitted the bug, and as for when they will fix it, I shall be steering clear of AI Suite for all eternity!

                      Comment


                      • #26
                        You don't need to reinstall Windows. Do Windows in-place upgrade.

                        Comment


                        • #27
                          MY RYZEN 5950X IS CRIPPLED BY THIS ALSO

                          I just recently tried out Passmark for the first time yesterday and was shocked to find my 5950X scores were WAY below what other users were getting. I am only getting one THIRD of the floating point performance according to these results. Is it that the results are not reporting correctly or I AM actually getting 1/3 performance overall in floating point in all applications now???

                          If it is the case that I am only getting 1/3 performance in this critical CPU operation (critical for all rendering work) then that could be grounds for legal class action lawsuit against ASUS for gross negligence and damages.

                          I seem to have latest version of this AI Suite installed ie. this:

                          Version 3.00.69
                          2020/10/28 165.61 MBytes
                          ASUS AI Suite 3 V3.00.69 Install Program for Windows 10 64-bit.
                          ASUS Dual Intelligent Processors 5 V2.00.54 for Windows 10 64-bit.
                          ASUS EZ Update V3.00.13 for Windows 10 64-bit.
                          ASUS System Information V2.00.09 for Windows 10 64-bit.

                          How can I fix this?? There is NO WAY I and not a chance I would go to the monumental effort of reinstalling Windows and hundreds of apps and configuration for this.

                          Comment


                          • #28
                            I am so glad I found this discussion. I was also getting very bad CPU scores after using Asus Dual Intelligent Processor 5.

                            I followed the advice mentioned above and did a "Windows 10 in-place upgrade".

                            See the difference from the pics! --> DELETE this bloatware

                            Click image for larger version

Name:	Before with AI suite 3.jpg
Views:	538
Size:	77.9 KB
ID:	51123Click image for larger version

Name:	no AI suite 3.jpg
Views:	504
Size:	80.9 KB
ID:	51124

                            Comment


                            • #29
                              Let me first thank you for providing PassMark Performance Test software and also discussing with users and ASUS about the issue.

                              Which is still not fixed. I just bought this board:
                              ASUS ROC-Strix B5550-E Gaming and Ryzen 9 5950X CPU.

                              And felt sad about the overall performance according to PassMark. Looking deeper I found this know issue and I confirm this still to be present. I have removed the "Dual something" software from ASUS, but it is the same as with users here: this does not fix the problem. An in-place Windows update I did not do so far.
                              Here are my results.
                              Click image for larger version

Name:	FlotingPointMath.png
Views:	189
Size:	31.1 KB
ID:	52986
                              There is one even worse case with Physics, because this really drops:
                              Click image for larger version

Name:	Physics.png
Views:	182
Size:	32.9 KB
ID:	52987
                              So my options are: re-install Windows in-place. Or get another board and return this one. I do understand now why a big reseller in Germany does not sell ASUS motherboards. The probably get to many returns and do not like this. As do I.

                              Any news from you, David?
                              Best regards, Martin

                              Comment


                              • #30
                                I'll check with ASUS to see if they actually released a fix to the public.
                                Hmmm, it seems one of our contacts at ASUS has gone. Not sure if we'll get an answer.

                                Update: ASUS replied, but their reply was ambiguous. There is a new release of AI Suite 3 (Version 3.01.10 from Jan 2022). But they can't provide a release notes and haven't really confirmed if anything was fixed.

                                As far as we can see AI Suite 3 doesn't do anything really useful and never needs to be installed. If you want to check your fan speeds and voltage levels just look in BIOS instead.

                                So given that it seems you can't fully uninstall it, the best advice is never to install it.

                                Comment

                                Working...
                                X