Announcement

Collapse
No announcement yet.

ryzen 9 5900x low scores, good temps and freqs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ryzen 9 5900x low scores, good temps and freqs

    Good evening, I am new here but I use passmark since a long time.
    I just updated my build with a ryzen 9 5900x a 360 AIO (bequite) 64 gb of ram (2x32gb crucial ballistix dual rank).
    I am having quite lower scores then the one on the baseline with it (the baseline is around 39000 overall and around 3500 single thread).
    I am having 35675 overall cpu score and 3178 singe thread score.
    I am writing here because I am quite desperate and I have spent the last 10 days trying everything I can.
    I cleared cmos...I tried using everything at default, I tried Precision Boost Override, curve optimizer (basically underclock), repasted the CPU and double checked the correct mounting of the AIO.
    The temps seems to be good....idle are around 30/35 during the test at default settings i cannot surpass 60 when all cores are at 100% load. Using PBO and curve optimizer I can just gain 30/40 single thread score and around 1000 total score. Also the frequencies seems to be on par or higher then the declared specs (4.5/4.6 all cores and 4.8/4.9 single core seen in ryzen master).Balanced or high power profile seems to do not change anything.
    Windows is just reinstalled 10 days ago. Drivers are all updated...same is true for the BIOS.
    I come from an Intel build (9900k and its passmark was alsways higher then the baseline) so I am new to AMD stuff....is there something that I may have overlooked?
    Some windows or bios settings to watch?

  • #2
    Can you post the individual results for each test in the CPU test suite.


    Comment


    • #3
      Sure...
      First image is with default settings (no overclock)





      Second is with some optimization (pbo2 curve optimizer negative per core, pbo2 max boost +200Mhz)



      Third image is a Cinebench r23 test, which seems to be in line with the baseline


      Attached Files
      Last edited by VirusAM; 01-17-2021, 10:19 PM.

      Comment


      • #4
        Other images showing temps and frequencies in different phases of the passmark test.
        Also there is an image of the peak frequencies











        Attached Files
        Last edited by VirusAM; 01-17-2021, 10:21 PM.

        Comment


        • #5

          This image here is from an user I know that sent me for comparison.
          The biggest difference appears to be floating point score (I have less then half his score), and single thread score.
          The others scores seems to be similar

          Click image for larger version  Name:	eysian.PNG Views:	0 Size:	68.2 KB ID:	49722I add an image from an
          Last edited by VirusAM; 01-17-2021, 10:26 PM.

          Comment


          • #6
            I have seen the things in these post with similar issues:

            Very low floating point math score. - PassMark Support Forums

            i7 7700 gtx 1070 very poor performance on cpu and 2D - PassMark Support Forums

            but, I uninstalled every bloatware software (windows update automatically installed ASUS software), and I did a full windows reinstall just 20 days ago when I changed cpu + mobo + ram.
            I am willing to reset windows again....but first I would like to try to understand what is happening....

            EDIT:

            I saw you suggested in another thread to try to change the number of process..
            So i did from 1 to 24...and these are the results (only for floating point).
            4390
            8815
            13337
            17869
            22299
            26511
            30556
            34507
            35737
            36323
            36802
            36658
            36372
            36779
            36354
            36268
            36324
            36110
            36304
            36290
            36298
            36577
            36672
            36345
            I watched my temps and frequencies...it never went max was 54 degrees with 4.850GHz clock speed on all cores (not overclocked by me...all auto from PBO2).
            I saw that everything scaled well from 1 to 8 processes...after it just didn't increase anymore.

            Last edited by VirusAM; 01-17-2021, 11:18 PM.

            Comment


            • #7
              Good evening, I know I flooded you with threads...but this one is important.
              As I didn't want to reinstall windows without being sure that it was a software problem, i tried something maybe crazy...but that can help us understand.
              I used this program (https://wintousb.uptodown.com/windows) to install Windows on an USB-c samsung t5 SSD.
              I then booted using that one (with nothing installed). Installed passmark, and this are the results I got.


              Click image for larger version  Name:	1.PNG Views:	0 Size:	80.4 KB ID:	49740

              So I can be happy that my hardware is indeed good, but something in my windows installation is ruining performances.
              Can we try to understand why before I will give up and reinstall windows (I plan to do that in the next weekend if we cannot find the cause)?
              Things I have done so far...
              I uninstalled all the ASUS software (my motherboard is a rog strix b550-e) and it asked to install ASUS ai suite when i first installed windows. But then I uninstalled it.
              I use also processlasso, MSI afterburner and hardwareinfo. But I disable all this software during my tests (without uninstalling it).
              Other then that it is just AMD chipset drivers and AMD Ryzen Master (which I tried to install and uninstall multiple times).
              Maybe this has something to do with some Windows settings?

              Comment


              • #8
                Ok...I think it is ASUS bloatware fault.
                I installed Asus AI Suite on my WinToUSB install, and the scores went down again.
                The problem is that uninstalling won't solve the issue.
                A lot of services remained installed on the machine, and also using programs like revouninstaller or CCcleaner won't change anything.
                I manually deleted everything I found which is ASUS related but still the issue is present.
                Maybe they change something in the operating system files which we are not aware of.

                Comment


                • #9
                  I think it is ASUS bloatware fault
                  Bloatware in general is a fairly common issue.
                  ASUS AI suite has been causing problems for years.
                  A post from 2017
                  https://forums.passmark.com/performa...7566#post37566

                  Comment


                  • #10
                    Hi,
                    Yes I read thought all these posts.
                    Initially I excluded this as a cause because I uninstalled it, before opening this thread as I was already trying to understand on my own.
                    The problem is that it is difficult to completely eradicate it as it leaves a lot of leftovers. I think I managed to do it, using ccleaner, and manually.
                    But the problem still remains....maybe it modifies something in the registry or some system files....Maybe if we understand this we could also help people that has the same issue.

                    Now a technical question....do you think that those lower scores in Passmark really means lower performances in gaming/computing?
                    I ask this question as in cinebench I see more or less the same scores also with this bloatware....
                    Thanks
                    Last edited by VirusAM; 01-19-2021, 11:51 AM.

                    Comment


                    • #11
                      do you think that those lower scores in Passmark really means lower performances in gaming/computing?
                      Yes. But for gaming the GPU will often be the bottleneck, so for many people it might not be noticeable.

                      Comment


                      • #12
                        Ok thanks.
                        So I did a Windows reset on the main install and scores were back to normal.
                        It would be nice however to understand what is causing the issue, which kind of modifications the ASUS software does that remains also after completely nuking it.
                        I think it would be helpful for future issues that people could still have.

                        Comment


                        • #13
                          Hi,
                          Just to add to this, I have had the same issue but with a Ryzen 5 5600x. I did a benchmark on the brand new install and I got normal CPU performance. I then installed ASUS AI Suite 3 and ever since I have low floating point math (down 20%) and poor single core performance (down 10%). It doesn't make any difference if I uninstall the software.

                          I've done a benchmark on Geekbench 5 and CPU-Z ROG and I'm seeing that single thread performance is completely normal, in other words average.

                          It would appear that there is some incompatibility between ASUS software and Passmark Performance Test.

                          As other benchmarks are normal, I question whether my CPU is actually running slower.

                          I have used Performance Test since version 5 and have always found it very useful for benchmarking. However now I'm losing a bit of confidence in it. I can't reinstall Windows just so I get a normal test result, considering I have a normal test result on other benchmarking software, but I would like to continue using Passmark.

                          What can I do? Thanks!

                          Comment


                          • #14
                            Results are good with a clean Windows install. Results are bad after ASUS AI Suite install. Results are good again if ASUS AI Suite is removed (although it looks like they didn't make this easy).

                            It isn't a "incompatibility" issue.

                            ASUS are screwing with the machine (the purpose of the software is in fact to screw with the machine). In my mind the conclusion is pretty clear who is at fault.

                            The more interesting question is how are they screwing with the machine to effect just one specific area of performance.

                            My guess (and it is really a guess without any evidence) is that they are messing around with the floating-point control word. Documentation is here
                            https://docs.microsoft.com/en-us/pre...52ceh(v=vs.140)
                            These settings can have a significant effect on performance. e.g. switching from 24bit precision to 64bit precision. My understanding is that the control word is normally stored per process, but ASUS are likely installing a kernel device driver, so anything is possible in terms of overriding the settings.

                            Their is an Intel paper here claiming 15% speed reduction as a result of more precise FP. But this will probably vary a lot depending on the code, CPU and compiler in use.
                            https://indico.cern.ch/event/166141/...FP_control.pdf
                            (Slide 25)

                            We will see if we can contact ASUS about it.

                            Information required
                            What motherboard model number was this?
                            Which (exact) version of AI Suite is this with. From the AI Suite 3 --> "Version" window. There should be a version number for "EZ Update", "Dual Intelligent Processor 5" and "System information"
                            BIOS version

                            Comment


                            • #15
                              Thanks for your reply. That's very interesting information. I'm completely wised up to the fact ASUS S/W is complete bloatware now and this is not to do with Performance Test. Clearly it has affected something which PT simply sheds light on. In fact in my attempts to remove all traces, I must have disturbed some hidden registry entries because now I can't run AI Suite 3. It says the fan control service can't start due to a missing file.

                              No matter, having reinstalled it all I could get the version numbers before cleaning it all off again.

                              Board is ROG Strix X570-I Gaming

                              AI Suite 3.00.55, containing the below versions of DIP 5, EZ Update etc.


                              Click image for larger version

Name:	Capture.JPG
Views:	307
Size:	18.6 KB
ID:	50095

                              Comment

                              Working...
                              X