No announcement yet.

./pt_linux_x64 doesn't work on my x64 machine

  • Filter
  • Time
  • Show
Clear All
new posts

  • ./pt_linux_x64 doesn't work on my x64 machine

    $ ./pt_linux_x64 # there is no output
    $ strace ./pt_linux_x64 # prints
    execve("./pt_linux_x64", ["./pt_linux_x64"], [/* 33 vars */]) = -1 ENOEXEC (Exec format error)
    write(2, "strace: exec: Exec format error\n", 32strace: exec: Exec format error
    ) = 32
    exit_group(1) = ?
    +++ exited with 1 +++

    and here is the information about my machine:
    Linux version 4.18.0 (gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.11)) #1 SMP Fri Sep 24 02:26:50 CST 2021

  • #2
    sorry, it's because my file upload is incomplete


    • #3
      OK, glad you sorted it out.


      • #4
        Originally posted by David (PassMark) View Post
        OK, glad you sorted it out.
        Unfortunately I have the same problem as the OP, but not a corrupted download. I'm running Ubuntu 20.04.3 LTS, and can't get past

        ./pt_linux_x64: error while loading shared libraries: cannot open shared object file: No such file or directory

        I already set LD_LIBRARY_PATH to /snap/core18/2128/lib/x86_64-linux-gnu where I located on my computer. However, I still get the same error message. What to do?

        Thanks, Rainer


        • #5
          See the FAQ question: 'I am getting "error while loading shared libraries: cannot open shared object file:
          No such file or directory?" error when I launch BurnInTest Linux from the command line, why?'

          On this page:

          Should apply for PerformanceTest as well.


          Some newer versions of Linux are now shipping with a newer version of ncurses (6) than BurnInTest was built with (eg Fedora 25). If you see this error messages you should be able to install "ncurses-compat-libs" which will install a version 5 compatible ncurses library. You can do this with "yum install ncurses-compat-libs".


          Some distributions split the ncurses library into several files and others use a single file. If you are missing the libtinfo library you can create a link from the ncurses library to it. First check where the library is being linked from by running the ldd command, eg "ldd bit_cmd_line_x32" it should be /lib or /usr/lib.

          Then create links to the ncurses library like this (changing /lib to /usr/lib if necessary);
          ln -s /lib/ /lib/
          ln -s /lib/ /lib/

          When using a 64 bit version of linux and running bit_cmd_line_x64 you would need to link the 64 bit libraries;

          ln -s /lib64/ /lib64/
          ln -s /lib64/ /lib64/


          • #6
            The same problem with outdated ncurses lib on Ubuntu 21.10 (./pt_linux_x64: error while loading shared libraries: cannot open shared object file: No such file or directory). The same will be with coming LTS release Ubuntu 22.04.
            Not possible to install "ncurses-compat-libs".
            Please compile with contemporary libraries.


            • #7
              You can still install libncurses5 in Ubuntu 21.10;

              sudo add-apt-repository universe
              sudo apt-get install libncurses5


              • #8
                Please compile with contemporary libraries
                Linux is a dumpster fire for binary compatibility.
                If we compiled with the newest library, then the software wouldn't work on even slightly old machines.