No announcement yet.

List of Motherboards with issues when running MemTest86 in multi-CPU selection modes

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    I've upgraded my Asus M5A97 Evo R2.0 with and now it works in paralllel for all cores. However MT86 v7.1 throws me errors on multiple tests which is not true. In fact, using Round Robin (which will utilize all cores eventually) in 10 passes I am not getting any errors. I am not getting any errors using older v4.3.7 in parallel CPU mode. Are you absolutely sure that your code do not have some regression??? Either BIOS patch from Asus or MT86 is not good. Using Windows Memory diagnostic (from W8.1), HCI design MemTest, MemTest86 4.3.7 and GoldMemory 7.85 pro do not find any errors for days


    • #47

      Can you supply some details of the errors.
      Emailing us the log might also help,


      • #48
        Hi, everybody!

        I have found the multi core freezing also.

        - Motherboard model number : ASUS Rampage V Extreme

        - BIOS version : 3402 (the most newest version)

        - CPU : Intel i7-5820K

        - Issue : Freeze on parallel, sequential, round robin in v7.2
        No problem in single cpu0 or 4.3.7 or old BIOS(2101 under)


        • #49
          - Gigabyte Z170-HD3P
          - BIOS "F5"
          - Intel i5-6500
          - MemTest86 v7 Free Ver 7.0
          - Runs only in single core (1) mode. All other modes crashed.

          After updating the motherboard firmware to F20 (Release Date Nov 9, 2016) MemTest86 ran in multi-core mode.


          • #50
            Hello everyone, have been testing and getting help from David for a few days now through email about some memory errors with dual channel mode in my new build. He directed me to this forum thread. Btw thanks a lot David for all the help!

            Only yesterday I ran the Sequential (All CPUs) tests for the first time, I can report that my Asus motherboard Maximus VIII Ranger also freezes when running those tests using Memtest86 v7.2 from the USB.

            Single-core and all-cores tests run with no problems for several hours. (No problems meaning, at least with the tests not freezing; they do find errors in dual channel mode, and always same address)

            But trying the Sequential, even testing just one DIMM freezes the machine only a couple of seconds after starting.

            Update: Round-robin also freezes the machine although not right away like the sequential. I have noticed that if I do the following it does freeze it:
            Start Memtest86, enter config
            Click CPU Selection
            Select RoundRobin
            Click Start Test ---> Seems to run fine. Let it run for half a minute or so; press escape and then go back to Main Menu

            Click CPU Selection
            Select Single CPU and choose any
            Click Start Test ---> Seems to run fine. Let it run for half a minuto or so; press escape and then go back to Main Menu

            Click CPU Selection
            Select again RoundRobin
            Click Start Test ----> Doesn't even start, it freezes completely

            Update 2: got replacement DIMMs and these seem ok. No errors after several passes of Memtest86 in single mode, dual mode, with 1 core, with all cores, no XMP, and with XMP. However the board still hangs with the Sequential, barely a couple of seconds after starting the tests, just like before. Left the Round-Robin running right after a reboot, and it seemed to have started fine, but in test #10 the machine was frozen.

            My system is this one:

            The mobo has the latest BIOS downloaded from Asus pages. CPU-Z reports itīs version 3007 from American Megatrends Inc.

            Full log sent by email. Below a photo of the frozen run, only three seconds after start:
            Attached Files
            Last edited by raulinbonn; Jan-23-2017, 10:04 PM.


            • #51
              Hello everyone,
              I recently downloaded the latest version of MemTest86 (v7.3), both the USB and the DVD version, because of annoying and critical BSODs apparently regarding the RAM. Because of the fact that I often work with DVDs, I created the bootable UEFI-DVD first. Everything went well and I restarted the machine, entered the UFEI-BIOS and selected my optical storage device as the first device to boot from (additionally, I changed in the BIOS the option for Storage Devices from 'Legacy only' to 'UEFI driver first). Then I started the process by booting from the DVD. At first it looked like it would work well (Retrieving hardware info etc.). However, now the machine seems to stand still at the point 'Testing multiprocessor support'. I waited patiently. But it is still displayed and no further progress seems to be made. I looked for that on the web and found some threads here in this forum. Often it was said that the logs would help. Bad for me because I run the DVD and so there are no logs created.
              After I was tired of waiting I stopped the process and restarted my system to create the bootable stick. Also there everything worked fine during the process of creating it. So the same procedure again. Restarting, selecting the bootable device (and for USB: setting from Partial Initialization to Full Initialization). Then I wanted to boot from the UEFI-USB but it did not want to. After I selected the bootable medium the monitor turned black for a short time (common, of course, because of leaving the BIOS). But now there was the strange thing. It did not want to boot the USB. I was immediately sent back to my BIOS and could not boot as often as I attempted to. Always the same. Then I tried to boot from the other version (not the UEFI), but then I got the notification that there was not an OS installed etc. After pressing a button I was redirected to my BIOS again - but the only difference was that I got a notification and was not redirected to the BIOS immediately.
              However, this is not the problem I am dealing with now.
              The one I am dealing with is the one when MemTest tests the multiprocessor support "for years" or rather it does not seem that there is any progress. So now I am asking for help, so that I will be able to boot MemTest successfully.

              Components I am using:
              Intel Core i7-6800K (Hexacore)
              ASUS Strix X99 Gaming (Running BIOS v.1401)
              CORSAIR Vengeance LPX 2400MHz DDR4 32GB @ 4x8GB
              ASUS GeForce GTX 1080 Strix Gaming (Advanced)

              Thank you very much for your help,


              • #52
                There is a slightly newer BIOS available for the ASUS Strix X99 Gaming, version 1504. So you could try that.

                If it didn't start the boot process at all from the USB drive, then it is a BIOS configuration issue.


                • #53
                  Originally posted by Morphi View Post
                  Hello everyone,
                  Components I am using:
                  Intel Core i7-6800K (Hexacore)
                  ASUS Strix X99 Gaming (Running BIOS v.1401)
                  It appears that the UEFI BIOS on your ASUS board suffers from the same multiprocessor issues as similar ASUS X99 boards listed in this thread. We can provide a build for you that will be able to get past the "Testing Multiprocessor support". Please send us an e-mail and we'll send you the build.


                  • #54
                    Originally posted by David (PassMark) View Post
                    If it didn't start the boot process at all from the USB drive, then it is a BIOS configuration issue.
                    Thank you very much for that suggestion. However, I can boot from USB. Actually, it is the same USB stick but I can boot the Windows image (UEFI as well) from it, even though it does not want to boot MemTest. So I would say that I can exclude that there might be a BIOS configuration issue? Or do you have any other proposals in this way?


                    • #55
                      There are some details here about configuring BIOS to boot MemTest86. However a booting problem isn't related to this topic (multi-threaded behaviour).


                      • #56
                        Just wanted to post a quick update for the "ASUS Prime B350-Plus" item in the list. Currently it lists BIOS version 0503 so wanted to mention that the newer 0513 and also the current latest beta 0605 still have the multiprocessor issue as mentioned in the referenced thread here:


                        • #57

                          I am attempting to run memtest v7 free under UEFI on a Intel R2224GZ4GC4 barebones server with dual Xeon E5-2670's and 128GB of ECC RAM. This server uses an Intel S2600GZ motherboard. I've updated the firmware/BIOS to what I believe is the most current (

                          When loading memtest it shows a banner saying (going off memory here) that my "UEFI BIOS might not fully support multi-processor".

                          I'm wondering how it knows this? Has someone already tested this motherboard/firmware and I'm being warning? Is it detecting some firmware "bug" and warning me? Or is it just warning me because "it doesn't know"?

                          Obviously it would be beneficial for speed if I could enable use multi-processor as the system has Dual Xeons with 32 cores total. And I have about 4 x 128GB sets of RAM to test.

                          Thank you for any assistance you can provide.


                          • #58

                            When launched MemTest86 runs a very short test to see if the UEFI BIOS support multi-threading. So it can detect when support isn't available (some of the time).


                            • #59
                              Hello sir,
                              sorry for my bad englich
                              Asus release a new bios for the Asus Rampage V Extreme X99.... 3701..
                              it fix memtest86 issue...
                              is the multicore support mean?
                              I have a 5960x and the Rampage V Extreme, i can test it for you but with which build?

                              But i have a bug with my nvidia 780ti and Gsync Monitor Acer XB270.
                              I run the test, turn monitor off....afer 2h i turn the monitor on and no signal for monitor but memtest run and log


                              • #60
                                Wow, thanks for pointing that out. They even listed the fix on their BIOS download page!

                                Version 3701
                                RAMPAGE V EXTREME BIOS 3701
                                Fixed memtest86 issue
                                Fixed Plextor device issue
                                8.31 MBytesupdate 2017/06/09